# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\w{2}-\w{2})/questions/(\w+)$"
test_str = ("en-us/questions/ask\n"
"en-us/questions/newest/15\n"
"en-us/questions/12/just-a-text-to-be-ignored\n"
"en-us/questions/newest")
subst = "/questions.aspx?lang=\\1&tab=\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.