const regex = /[a-zA-Z\.]{1,128}\.([a-zA-Z\_]{1,})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-zA-Z\\.]{1,128}\\.([a-zA-Z\\_]{1,})', 'g')
const str = ` fs.id as swid,
maxgames.type_id,
maxgames.game.game_id,
maxgames.game.game_name,
maxgames.entry_id,
maxgames.entry_nickname,
maxgames.season_id,
maxgames.groups,
maxgames.rank,
maxgames.sort_global,
maxgames.points,
maxgames.create_date,
maxgames.last_update,
fs.year,
fs.month,
fs.date`;
const subst = `$0 AS $1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);