# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:.*?one.*?){1}.*?)one/\1\(one\)/m;t' <<< "one two three one one asdfasdf one asdfasdf sdf one
"