using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:.*?one.*?){1}.*?)one";
string substitution = @"\1\(one\)";
string input = @"one two three one one asdfasdf one asdfasdf sdf one
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}