const regex = /((?:.*?one.*?){1}.*?)one/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:.*?one.*?){1}.*?)one', 'm')
const str = `one two three one one asdfasdf one asdfasdf sdf one
`;
const subst = `\1\(one\)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);