use strict;
my $str = 'one two three one one asdfasdf one asdfasdf sdf one
';
my $regex = qr/((?:.*?one.*?){1}.*?)one/mp;
my $subst = '\\1\\(one\\)';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";