// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:.*?one.*?){1}.*?)one").unwrap();
let string = "one two three one one asdfasdf one asdfasdf sdf one
";
let substitution = "\\1\\(one\\)";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}