use strict;
my $str = 'simple@example.com
disposable.style.email.with+symbol@example.com
fully-qualified-domain@example.com
user.name+tag+sorting@example.com
';
my $regex = qr/^(?!.{67})[A-Za-z0-9.\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\;=`+’!^<>\[\]]+@(([A-Za-z0-9\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\;=`+’!^<>\[\]]+\.[A-Za-z0-9.\-–—_ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\;=`+’!^<>\[\]]*[A-Za-z0-9ÞÀÁÂÃÄÅÆàáâãäåæßÇç¢ÐÈÉÊËèéêëƒÌÍÎÏìíîïðÑñÒÓÔÕÖØŒòóôõöøœŠšÙÚÛÜùúûüµþŸÝÿýžŽ?'*/\;=`+’!^<>\[\]]{2,})|(\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\]))$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}