const regex = new RegExp('(?=\\S{10,})(?=\\S*[A-Z])(?=\\S*[a-z])(?=\\S*[0-9])(?=\\S*[!£$%^&\\"])(?<!\\S)\\S{10,20}(?=\\s|\\Z)', 'g')
const str = `Password!123
Password!123 test test
test "Password!123" test test
9: Abc!56789
10: -Ab!567890
20: -Ab!567890DeF4567890
21: AbC!567890DeF45678901
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}