re = /(^.*\/).*/m
str = 'http://xxxx.com/xxx-xxx-xxx-xxxx/ 60% 2 Weekly 2014-01-01 00:00
http://somethingelse.com/123-456-789-0000/ 60% 2 Weekly 2014-01-01 00:00
http://anothersite.com/page/boop/beep/ 60% 2 Weekly 2014-01-01 00:00
http://baloogawhalesarenotaliens.com/ 60% 2 Weekly 2014-01-01 00:00
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result