using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*\/([^\/]+)\/([^\/]+)\/([^\/]+)\?ds=.*$";
string input = @"file://server-name-01/e$/(any file or subfolder)?ds=test_01
file://server-name-02/e$/(any file or subfolder)?ds=test_01
file://server-name-03/e$/(any file or subfolder)?ds=test_01 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}