package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*\/([^\/]+)\/([^\/]+)\/([^\/]+)\?ds=.*$`)
var str = `file://server-name-01/e$/(any file or subfolder)?ds=test_01
file://server-name-02/e$/(any file or subfolder)?ds=test_01
file://server-name-03/e$/(any file or subfolder)?ds=test_01 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}