import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*\\/([^\\/]+)\\/([^\\/]+)\\/([^\\/]+)\\?ds=.*$";
final String string = "file://server-name-01/e$/(any file or subfolder)?ds=test_01\n"
+ "file://server-name-02/e$/(any file or subfolder)?ds=test_01\n"
+ "file://server-name-03/e$/(any file or subfolder)?ds=test_01 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}