re = /^.*\/([^\/]+)\/([^\/]+)\/([^\/]+)\?ds=.*$/m
str = 'file://server-name-01/e$/(any file or subfolder)?ds=test_01
file://server-name-02/e$/(any file or subfolder)?ds=test_01
file://server-name-03/e$/(any file or subfolder)?ds=test_01 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end