package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\d]*\.?[\d]+?|[\d]+\.`)
var str = `.
1.
1.23
1
.23`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}