#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\[\^([\s\S]*?)\]"
Local $sString = "Then he said FUCKIT[^This is where I need to insert some MD] you're all going to hell" & @CRLF & _
"" & @CRLF & _
"Then he said FUCKIT[^it " & @CRLF & _
"should" & @CRLF & _
"" & @CRLF & _
"]s" & @CRLF & _
"be multiline] you're all going to hell" & @CRLF & _
"" & @CRLF & _
"Then he said FUCKIT[^it " & @CRLF & _
"should " & @CRLF & _
"#contain MD" & @CRLF & _
"be multiline] you're all going to hell" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(?=\])"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")