using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\^([\s\S]*?)\]";
string input = @"Then he said FUCKIT[^This is where I need to insert some MD] you're all going to hell
Then he said FUCKIT[^it
should
]s
be multiline] you're all going to hell
Then he said FUCKIT[^it
should
#contain MD
be multiline] you're all going to hell
(?=\])";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}