const regex = /^.*(\S*)\({1}.*ref\s*SqlConnection/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*(\\S*)\\({1}.*ref\\s*SqlConnection', 's')
const str = `public static bool InsertNote(string TableName, string TableKey, string DocType, string InsuredKey, string SubmissionKey,
string Staff, string DefaultAction, string DisplayKey, FileType FileType, string IFSFileName,
string IFSFolder, string IFSTimeStamp, string Subject, string Notation, NoteType NoteType,
//string Company, string NoteCategory, ref OracleConnection Connection)
string Company, string NoteCategory, string DocumentName, ref SqlConnection Connection)
{`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}