$re = '/<a.*?>\s*([^<\s](?:[^<]*[^<\s])*)\s*</i';
$str = '<ul>
<li><a href="https://www.google.ru/?q=Darth+Vader">Darth Vader</a></li>
<li><a href="https://www.google.ru/?q=Anakin+Skywalker">Anakin Skywalker</a></li>
</ul>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);