#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "("(?=-?\d*\.?\d+E[+-]?\d+)|(?<=E9)")"
Local $sString = "{"friend_count":30,"session_id":"e206d0c0-e369-4fe4-a950-9494bd540306","user_agent":"Snapchat\\/9.11.9870.02 Beta (GT-I9300; Android 4.3; gzip)","user_id":"mishgurudev","sequence_id":302,"client_ts":"1.436251509065E9","eventName":"APP_SESSION_END","session_time_sec":3582,"session_active_time_sec":3564,"session_start_ts":"1.436230017065E9","client_upload_ts":1436251509065}{"friend_count":30,"session_id":"e206d0c0-e369-4fe4-a950-9494bd540306","user_agent":"Snapchat\\/9.11.9870.02 Beta (GT-I9300; Android 4.3; gzip)","user_id":"mishgurudev","sequence_id":302,"client_ts":"1.436251509065E9","eventName":"APP_SESSION_END","session_time_sec":3582,"session_active_time_sec":3564,"session_start_ts":"1.436230017065E9","client_upload_ts":1436251509065}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")