# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\"(?=-?\d*\.?\d+E[+-]?\d+)|(?<=E9)\")"
test_str = "{\"friend_count\":30,\"session_id\":\"e206d0c0-e369-4fe4-a950-9494bd540306\",\"user_agent\":\"Snapchat\\\\/9.11.9870.02 Beta (GT-I9300; Android 4.3; gzip)\",\"user_id\":\"mishgurudev\",\"sequence_id\":302,\"client_ts\":\"1.436251509065E9\",\"eventName\":\"APP_SESSION_END\",\"session_time_sec\":3582,\"session_active_time_sec\":3564,\"session_start_ts\":\"1.436230017065E9\",\"client_upload_ts\":1436251509065}{\"friend_count\":30,\"session_id\":\"e206d0c0-e369-4fe4-a950-9494bd540306\",\"user_agent\":\"Snapchat\\\\/9.11.9870.02 Beta (GT-I9300; Android 4.3; gzip)\",\"user_id\":\"mishgurudev\",\"sequence_id\":302,\"client_ts\":\"1.436251509065E9\",\"eventName\":\"APP_SESSION_END\",\"session_time_sec\":3582,\"session_active_time_sec\":3564,\"session_start_ts\":\"1.436230017065E9\",\"client_upload_ts\":1436251509065}"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.