re = /\<elem\skey=\"fqdn\"\>(?<fullDomainName>[^\<]+)<\/elem\>/
str = '<elem key="date">2016-11-27T13:01:38+01:00</elem>
<elem key="fqdn">XXXXXXXXX.mydomain.domain.com</elem>
<elem key="domain_dns">mydomain.domain.com</elem>
<elem key="forest_dns">domain.com</elem>
<elem key="workgroup">XXX\\x00</elem>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end