$re = '/\.?0+$/m';
$str = '0.24000
4.1100
200
0.100
1.0
123.450
123.400
123.456
123.000';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;