re = /^.*?_ExampleXML_(.*?)_[^_]+\.xml$/m
str = 'First_ExampleXML_Only_This_Should_Be_Name_20211234567.xml
Second_ExampleXML_OnlyThisShouldBeName_202156789.xml
Third_ExampleXML_Only_This_Should_Be_Name1_2021445678.xml
Fourth_ExampleXML_Only_This_Should_Be_Name2_20214567.xml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end