#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?imu)^(?<tz_utf>(?:\([^)]+\)|[^-]+)+)\s+-\s+(?<tz>[^:]+)\s+:\s+(?<fr>[^/]+)\s+/\s+(?<en>[^/]+)\s+/\s+(?<ar>\S+)\s+(?<tz_dec_utf>[ⴰ-⵿ -]+)\s+(?<tz_dec>.*)$"
Local $sString = "ⵜⴰⵙⵎⵙⵙⵉⵜ - tasmessit : Focalisée / Focus / QCÉÑe ⵜⴰⵙⵎⵙⵙⵉⵜ - ⵜⵙⵎⵙⵙⵉⵜ - ⵜⵉⵙⵎⵙⵙⵉⵜⵉⵠtasmssit - tsmssit - tismssitin" & @CRLF & _
"ⵜⴰⵙâµâ´°âµ¥âµ–ⵓⵕⵜ ( âµ-) - tasnaÇvurt (n-) : Etymologique / Etymological / »dÉKCG ⵠⵜⵙâµâ´°âµ¥âµ–ⵓⵕⵜ n tesnaÇvurt" & @CRLF & _
"ⵜⴰⵙⵖⵓâµâµœ ⵜⴰâµâ´°â´·â´°âµ¡âµœ - tasvunt tanadawt : Subordonnant / Subordinating (conjunction) / §HGQ ⵜⴰⵙⵖⵓâµâµœ ⵜⴰâµâ´°â´·â´°âµ¡âµœ - ⵜⵉⵙⵖⵡⴰⵠⵜⵉâµâ´°â´·â´°âµ¡âµ‰âµ tasvunt tanadawt - tisevwan tinadawin"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")