const regex = /(?:\G(?!^)|render\(')[^':]*\K:+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)|render\\(\')[^\':]*\\K:+', 'gm')
const str = `render('MyBundle:Default:index.html.twig')
or render('MyBundle::Default::index.html.twig')`;
const subst = `/`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);