use strict;
my $str = 'render(\'MyBundle:Default:index.html.twig\')
or render(\'MyBundle::Default::index.html.twig\')';
my $regex = qr/(?:\G(?!^)|render\(')[^':]*\K:+/mp;
my $subst = '/';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";