$re = '/(?:\G(?!^)|render\(\')[^\':]*\K:+/m';
$str = 'render(\'MyBundle:Default:index.html.twig\')
or render(\'MyBundle::Default::index.html.twig\')';
$subst = "/";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;