re = /(?:\G(?!^)|render\(')[^':]*\K:+/m
str = 'render(\'MyBundle:Default:index.html.twig\')
or render(\'MyBundle::Default::index.html.twig\')'
subst = '/'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result