#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=\d)(\d{3})(?!\d)"
Local $sString = "100000" & @CRLF & _
"?100000?50000" & @CRLF & _
"X10000.5?" & @CRLF & _
"" & @CRLF & _
"100,000" & @CRLF & _
"" & @CRLF & _
"123456789" & @CRLF & _
"1.9876" & @CRLF & _
""
Local $sSubst = ",$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)