using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\d)(\d{3})(?!\d)";
string substitution = @",$1";
string input = @"100000
?100000?50000
X10000.5?
100,000
123456789
1.9876
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}