$re = '/(\d\d?(?::\d\d)?)\s+to\s+(\d\d?(?::\d\d)?)/s';
$str = '8:30 to 17:00
8 to 18
09:00 to 14:30';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);