Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?!\d\.\d)(\w\.+)(?! )(\w?)
/
gm
Test String
New
This is a sample text. Just 1.2 to test.To add a space after the dot...Okay. I watched football.10 people played in 2 teams, my friend was player number 7. 20 minutes later the game ended with the score 2:1.Then I went home.