using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/(?!\.well-known\/).*";
string input = @"/.well-known/acme-challenge
/.well-known/acme-challenge/
/.well-known/acme-challenge/12312312sffsdaf
/
/some-page
/some-page/cool";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}