$re = '/(?<!\\\\)(?:\\\\{2})*\K{aaa}/';
$str = 'this is a test called \\\\{aaa} and this is a test called \\{aaa} and {aaa}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);