#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\G(?!^)|^(?=.*string3)).*?\Kstring1"
Local $sString = "This is line string1" & @CRLF & _
"This is line two with string1 and string3 string1" & @CRLF & _
"This is line two with string1 string1 and string3 " & @CRLF & _
"This is line three with string3" & @CRLF & _
"This is line string3 with string1 and string1"
Local $sSubst = "string2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)