use strict;
my $str = '<FORMAT=T>8</FORMAT><FORMAT=ty>45</FORMAT>';
my $regex = qr/<FORMAT=T>(\d+)</FORMAT>/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";