re = /SPECGRID([\s\S]*?)\//
str = 'MAPAXES -- Generated : Petrel
159589.61 7782837.94 159589.61 7783837.94 160589.61 7783837.94 /
GRIDUNIT -- Generated : Petrel
METRES /
SPECGRID -- Generated : Petrel
3 26 120 1 F /
COORDSYS -- Generated : Petrel
1 120 /
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end