import Foundation
let pattern = #"SPECGRID([\s\S]*?)\/"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
MAPAXES -- Generated : Petrel
159589.61 7782837.94 159589.61 7783837.94 160589.61 7783837.94 /
GRIDUNIT -- Generated : Petrel
METRES /
SPECGRID -- Generated : Petrel
3 26 120 1 F /
COORDSYS -- Generated : Petrel
1 120 /
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}