$re = '/^(8)[\s(-]{0,3}[0-9]{3}[\s)-]{0,3}[0-9]{3}[\s-]{0,3}[0-9]{2}[\s-]{0,3}([0-9]{2})$/u';
$str = '8-911-50-656-33';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);