re = /[\\\/]JAXB[\\\/].+?[\\\/]classes[\\\/][A-Z]/
str = 'D:\\workspace\\Project\\src\\com\\tj\\JAXB\\foo\\bar/classes\\FooClass.java'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end