#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?ms)\bvirtual\b\s*(.+?)\s*\boverride\s*(.+?)"
Local $sString = "virtual void test1() const override;" & @CRLF & _
"" & @CRLF & _
"virtual int test2() override { xxx } //an example of commentary" & @CRLF & _
"" & @CRLF & _
"virtual void test3(int p1," & @CRLF & _
" int p2," & @CRLF & _
" int p3) const override;" & @CRLF & _
"virtual void test4(int p1," & @CRLF & _
" int p2," & @CRLF & _
" int p3," & @CRLF & _
" int p4) const override;" & @CRLF & _
"" & @CRLF & _
"virtual void testn(int p1," & @CRLF & _
" int p2," & @CRLF & _
" int p3," & @CRLF & _
" int p4," & @CRLF & _
" ......," & @CRLF & _
" int pn) const override;" & @CRLF & _
""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)