using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bvirtual\b\s*(.+?)\s*\boverride\s*(.+?)";
string substitution = @"$1$2";
string input = @"virtual void test1() const override;
virtual int test2() override { xxx } //an example of commentary
virtual void test3(int p1,
int p2,
int p3) const override;
virtual void test4(int p1,
int p2,
int p3,
int p4) const override;
virtual void testn(int p1,
int p2,
int p3,
int p4,
......,
int pn) const override;
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}