import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?ix)\n"
+ "(\\d+:\\d\\d)\n"
+ "\\s+\n"
+ ".*?\n"
+ "\\b\n"
+ "(\n"
+ " mon(?:d(?:ay?)?)\n"
+ "|tue(?:s(?:d(?:ay?)?)?)?\n"
+ "|wed(?:n(?:e(?:s(?:d(?:ay?)?)?)?)?)?\n"
+ "|thu(?:r(?:s(?:d(?:ay?)?)?)?)?\n"
+ "|fri(?:d(?:ay?)?)\n"
+ "|sat(?:u(?:r(?:d(?:a)?)?)?)?(?:y)?\n"
+ "|sun(?:d(?:ay?)?)\n"
+ ")\n"
+ ".*";
final String string = "0:18 on Tuesday's mini\n"
+ "1:43 Wednesday. dang!\n"
+ "2:01 this Sat 😎";
final String subst = "$1 $2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}