re = /x\([^8\s]*8[^8\s]*\)/
str = '39x(7,8)
3x(8)
2x(8,1)
3x(8,9)
1x(11)
3x(11,7,8)
11x(11,7,8,9)
11x(11,7,88,9)
31x(11,7,8,9,10)
1x(11,7,8,9,10,12)
2x(7,8,10)
224x(7,8,9)
31x(11,7,8,9,10)
1x(11,7,9,10,12)
2x(7,8,10)
224x(7,8,9)
13x(7,8,9,10)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end