// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"x\([^8\s]*8[^8\s]*\)").unwrap();
let string = "39x(7,8)
3x(8)
2x(8,1)
3x(8,9)
1x(11)
3x(11,7,8)
11x(11,7,8,9)
11x(11,7,88,9)
31x(11,7,8,9,10)
1x(11,7,8,9,10,12)
2x(7,8,10)
224x(7,8,9)
31x(11,7,8,9,10)
1x(11,7,9,10,12)
2x(7,8,10)
224x(7,8,9)
13x(7,8,9,10)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}