#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\\\\r\\\\n)(?:(?!\\\\r\\\\n)[\w\W])*?(?=\\\\r\\\\n=)"
Local $sString = "# Heading Level 1\\r\\n## Heading Level 2\\r\\n### Heading " & @CRLF & _
"Level 3\\r\\n#### Heading Level" & @CRLF & _
"4\\r\\n##### Heading Level 5\\r\\n###### Heading Level 6\\r\\nHeading Level 13" & @CRLF & _
"Alternate\\r\\n======================\\r\\n"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")