using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\\\\r\\\\n)(?:(?!\\\\r\\\\n)[\w\W])*?(?=\\\\r\\\\n=)";
string input = @"# Heading Level 1\\r\\n## Heading Level 2\\r\\n### Heading
Level 3\\r\\n#### Heading Level
4\\r\\n##### Heading Level 5\\r\\n###### Heading Level 6\\r\\nHeading Level 13
Alternate\\r\\n======================\\r\\n";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}