import Foundation
let pattern = #"(?<=\\\\r\\\\n)(?:(?!\\\\r\\\\n)[\w\W])*?(?=\\\\r\\\\n=)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #######"""
# Heading Level 1\\r\\n## Heading Level 2\\r\\n### Heading
Level 3\\r\\n#### Heading Level
4\\r\\n##### Heading Level 5\\r\\n###### Heading Level 6\\r\\nHeading Level 13
Alternate\\r\\n======================\\r\\n
"""#######
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)