package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\W|_\b|\b_`)
var str = `!_!START_END`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}